CXone Mpower Expert - Service Disruption Resolved - All Services Running Normally.
Posted Oct 20, 2025 - 23:34 UTC
Monitoring
At this time we are now seeing GenSearch work as intended after further updates from Amazon Web Services. We will be monitoring further to make sure everything remains stable.
Posted Oct 20, 2025 - 21:36 UTC
Update
We are now seeing the issue reports loading as intended. GenSearch is still intermittent but we are awaiting further Amazon updates.
Posted Oct 20, 2025 - 20:30 UTC
Update
Amazon Web Services has updated that they are still working on mitigating the current issues and a fix is in validation process. Once we receive any further updates we will post those.
Posted Oct 20, 2025 - 19:56 UTC
Update
Amazon Web Services has updated that they are still working on mitigating the current issues and a fix is in validation process. Once we receive any further updates we will post those.
Posted Oct 20, 2025 - 18:35 UTC
Update
Amazon Web Services has updated that they are still working on mitigating the current issues and a fix is in validation process. Once we receive any further updates we will post those.
Posted Oct 20, 2025 - 17:17 UTC
Identified
CXone Mpower Expert - Service Degradation detected - There is currently an active service degradation with Amazon Web Services which is causing degradation with GenSearch and some reports in Expert. We are awaiting further updates from Amazon and we will post those as they are received.
Posted Oct 20, 2025 - 16:26 UTC
This incident affected: Application (General Service), Search, Generative Search, In-Product Contextual Help, MindTouch Success Center, Analytics, and Geoblocking for Russia.