CXone Mpower Expert - Service Disruption Resolved - All Services Running Normally. The CXone Mpower Expert Engineering team has deployed a fix and monitored the deployment to make sure sites are stable. The issue is now resolved at this time. Event duration (37m)
Posted Oct 20, 2025 - 09:59 UTC
Monitoring
CXone Mpower Expert - Fix Deployed - All Services Running Normally. Amazon Web Services has advised that significant recovery has been made on their end. We are seeing all services are running normally. We are currently monitoring sites for deployment stability. Event duration (37m)
Posted Oct 20, 2025 - 09:38 UTC
Update
We have confirmed our sites are down because of an issue from Amazon Web Services. Their last update indicated they have identified the issue and are working on multiple parallel paths to accelerate recovery. As we received any further updates we will post them.
Posted Oct 20, 2025 - 09:17 UTC
Identified
CXone Mpower Expert Service Degradation: Sites may be may be experiencing issues. The CXone Mpower Expert Engineering team is investigating reports of site unavailability.
Posted Oct 20, 2025 - 09:00 UTC
This incident affected: Application (General Service), Search, In-Product Contextual Help, Email Services, MindTouch Success Center, Analytics, and Geoblocking for Russia.